Author Topic: WFM Web Login Page  (Read 3030 times)

steveb

  • Guest
WFM Web Login Page
« on: October 06, 2006, 01:53:50 AM »
Just when you thought everything was going according to the manual (that'll be a first!), I've fallen at the last fence. I've installed Genesys WFM 7.1 on Tomcat. Got the latest version (5.5), using latest JRE from the Java site according to the WFM manual. Got Config Utility/DB Utility running fine, synching with CME no problem, and get the wfm login page up. However, when I log in with WFMAdmin (Admin user in WFM and Administrators Group in CME), I get two browsers. One - with the Genesys logo and Workforce Management title page, then a separate pop-up window. I see the 'loading Java' animation, then 'Hit Spacebar or Enter to use this control'. Did that, nothing. No option to refresh the source, nothing.

Checked the following - turned off all antivirus/pop-up blockers (this is a devt PC), set Internet Explorer security and privacy levels to the lowest.

Would be really grateful for some guidance here. And I'm sure there are plenty of us in this forum who have yet to do a full WFM install, so I'm sure it will be useful when we crack this 'buggette'.

Thanks in advance!

Steve

Offline René

  • Administrator
  • Hero Member
  • *****
  • Posts: 1763
  • Karma: 55
Re: WFM Web Login Page
« Reply #1 on: October 06, 2006, 05:29:42 AM »
Hi Steve,

Could you specify precise version of WFM you installed? It's important to know because Tomcat 5.5 is supported starting 7.1.2 and Java 5.x is supported starting 7.1.1.

Generaly I would advise you to enable Java console using Java applet in Control Panel and check for any error when loading of WFM Supervisor applet fails.

Hope it's helps
René




steveb

  • Guest
Re: WFM Web Login Page
« Reply #2 on: October 06, 2006, 05:54:12 PM »
Hi Rene,

WFM web is version 7.1.100.04. Perhaps I've overshot by using the latest version of Tomcat (5.5). Will rollback to 5.0 and post the results. Thanks Rene!

WFM Web 7.0 = Tomcat 4.1
WFM Web 7.1 = Tomcat 4.1 - 5.0 + Sun J2SE 1.4.1-1.4.2
WFM Web 7.1.1 = Tomcat 4.1 - 5.0 + Sun J2SE JDK 1.4.x or 5.0


Steve

tony

  • Guest
Re: WFM Web Login Page
« Reply #3 on: October 06, 2006, 08:25:22 PM »
Steve,

I'd be interested to know if you have also considered the suggestions I sent to you, off-line.

Thanks,

Tony

steveb

  • Guest
Re: WFM Web Login Page
« Reply #4 on: October 21, 2006, 02:08:56 AM »
YES!! YES!! YES!!

OK, you may have guessed I finally cracked it (with a little help from my friends, as Marty Pellow said).

In summary, I moved away from Windows XP Pro (SP2) since it was suggested Tomcat/JRE may have had a problem with specific XP versions. Although the WFM server components install on XP (and XP is listed in the ip..xml file), I moved to a clean Windows 2003 Server machine.

Using WFM 7.1.1, I installed Java j2sdk1.4.2_12 and Tomcat 5.0.28, which match the Genesys guidelines as per my previous post.

I meticulously followed the manual and used the wizards. Double-checked the start info properties and made sure everything was OK. Checked all the connections (it threw me when you have WFM Builder and WFM Server acting as both client and server to each other!).

Got the WFM Login page to give me a diffferent error this time - invalid logon/password, then spent ages checking I'd got the access groups and ranks correct in CME. Nearly fell at the last hurdle - almost forgot to add my logon as a user in WFM Config Utility.

Thanks again for all the advice, both on here and the offline messages. If anyone has similar problems, I'd be happy to share configs/settings etc.

Steve